Düşeyara ile sayfalar ve dosyalar arası veri çekmek

Excel’de olmazsa olmazımız düşeyara formülünü en pratik şekilde kullanmanız için iki model paylaşacağım. Daha önce kullanmadıysanız çağ atlamaya hazır olun.

Formül iki sayfada veya dosyada eşit olan verileri eşleştirerek, diğer sütunlardaki verileri işlemenize, çekmenize yarıyor.

1.Formül (sayfalar arası)

=EĞERHATA(DÜŞEYARA(D2;Sayfa3!A:G;5;0);"")

Düzenlemeniz gereken alanlar;

  • D2
  • Sayfa3
  • A:G
  • 5;0

Aynı dosyada, sayfalar arası veri çekmek için kullanılır. Ne gibi durumlarda kullanabileceğinizi listeliyorum.

  • Satış listenize yeni fiyat listenizdeki fiyatları eklemek
  • Satış ve iade işlemleriniz ayrı dosyalarda ise birleştirmek
  • Personellere özel farklı listeler varsa isimleri eşleştirerek birleştirmek

Bunlara benzer sayısız işlemde kullanabilirsiniz.

İki sayfada da sabit veriler olmalıdır.

2. Formül (dosyalar arası)

Dosyalar arası veri çekmek için kullanılır. Bir önceki örnekte olan sayfalar arası işlemi, bilgisayarınızda bulunan diğer dosyalar arasında yapar.

=EĞERHATA(DÜŞEYARA(D2;[dosyaadı.xlsx]Sayfa3!A:G;3;0);"")   

Daha iyi anlamanız için örnek

İlk sayfanızın A sütununda 50 isim ve bu isimlerin karşısında izin gün sayıları var.

Diğer sayfada ise, A sütununda 70 isim ve bir önceki yıla ait izin günleri var.

Kurgu şu olsun; geçen sene 70 personelimiz vardı, bu sene o 70 personelden 50 personelimiz kaldı.

Şimdi 50 personelin bu sene ve geçen seneki izinlerini bir araya toplayacağız.

İlk formülü ilk sayfada kullanarak, ikinci sayfadaki isimleri eşleştiriyor ve izin sayılarını yeni listeye çekiyoruz.

Anasayfa > Excel > Düşeyara ile sayfalar ve dosyalar arası veri çekmek

“Düşeyara ile sayfalar ve dosyalar arası veri çekmek” üzerine 2 yorum

  1. İşte böyle ihtiyacımız olan bilgiye hemen ulaşabilmemizi sağladığınız için teşekkür ediyorum. O kadar işime yaradı ki, sağ olun.

    Cevapla

Yorum yapın